summaryrefslogtreecommitdiff
path: root/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.0.ebuild')
-rw-r--r--dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.0.ebuild b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.0.ebuild
new file mode 100644
index 000000000000..f6ee577371cf
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.006000
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="An exporter with the features of Sub::Exporter but only core dependencies"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Warnings
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PERL_RM_FILES=(
+ inc/Test/Fatal.pm
+ inc/Test/Requires.pm
+ inc/Try/Tiny.pm
+ inc/archaic/Test/Builder.pm
+ inc/archaic/Test/Builder/IO/Scalar.pm
+ inc/archaic/Test/Builder/Module.pm
+ inc/archaic/Test/Builder/Tester.pm
+ inc/archaic/Test/Builder/Tester/Color.pm
+ inc/archaic/Test/More.pm
+ inc/archaic/Test/Simple.pm
+ SIGNATURE
+)