summaryrefslogtreecommitdiff
path: root/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
new file mode 100644
index 000000000000..98dfe3271f2a
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.42
+DIST_EXAMPLES=("bench/*")
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"