summaryrefslogtreecommitdiff
path: root/dev-perl/Dist-Zilla
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/Dist-Zilla
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/Dist-Zilla')
-rw-r--r--dev-perl/Dist-Zilla/Dist-Zilla-6.15.0-r1.ebuild157
-rw-r--r--dev-perl/Dist-Zilla/Dist-Zilla-6.15.0.ebuild154
-rw-r--r--dev-perl/Dist-Zilla/Manifest4
-rw-r--r--dev-perl/Dist-Zilla/files/Dist-Zilla-6.015-authordeps-missing.patch36
4 files changed, 351 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla/Dist-Zilla-6.15.0-r1.ebuild b/dev-perl/Dist-Zilla/Dist-Zilla-6.15.0-r1.ebuild
new file mode 100644
index 000000000000..4485c5f5469c
--- /dev/null
+++ b/dev-perl/Dist-Zilla/Dist-Zilla-6.15.0-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=6.015
+inherit perl-module
+
+DESCRIPTION="distribution builder; installer not included!"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+## CPAN->Gentoo resolution map for grepping in case upstream split a dep
+# breaks: Dist::Zilla::App::Command::stale -> Dist-Zilla-Plugin-PromptIfStale
+# DZA:Command::xtest -> DZP:CheckExtraTests
+# DZP:Author::Plicease::Tests -> DZPB::Author::Plicease
+X_BREAKS="
+ !<dev-perl/Dist-Zilla-Plugin-PromptIfStale-0.40.0
+ !<=dev-perl/Dist-Zilla-App-Command-update-0.40.0
+ !<dev-perl/Dist-Zilla-Plugin-CheckExtraTests-0.29.0
+ !<=dev-perl/Dist-Zilla-PluginBundle-Author-Plicease-2.20.0
+ !<dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild-0.161.230
+ !<=dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild-Filtered-0.1.0
+ !<=dev-perl/Dist-Zilla-Plugin-Git-2.36.0
+ !<=dev-perl/Dist-Zilla-Plugin-Keywords-0.6.0
+ !<dev-perl/Dist-Zilla-Plugin-MakeMaker-Awesome-0.220.0
+ !<=dev-perl/Dist-Zilla-Plugin-NameFromDirectory-0.30.0
+ !<=dev-perl/Dist-Zilla-Plugin-PodWeaver-4.6.0
+ !<=dev-perl/Dist-Zilla-Plugin-Prereqs-AuthorDeps-0.5.0
+ !<dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.161.170
+ !<=dev-perl/Dist-Zilla-Plugin-Run-0.35.0
+ !<=dev-perl/Dist-Zilla-Plugin-Test-CheckDeps-0.13.0
+ !<=dev-perl/Dist-Zilla-Plugin-Test-Version-1.50.0
+ !<=dev-perl/Dist-Zilla-Plugin-TrialVersionComment-0.3.0
+"
+# r: App::Cmd::Command::version -> App-Cmd-0.321
+# r: App::Cmd::Setup -> App-Cmd
+# r: App::Cmd::Tester -> App-Cmd
+# r: App::Cmd::Tester::CaptureExternal -> App-Cmd 0.314
+# r: CPAN::Meta::Converter -> CPAN-Meta
+# r: CPAN::Meta::Merge -> CPAN-Meta 2.142060
+# r: CPAN::Meta::Prereqs -> CPAN-Meta
+# r: CPAN::Meta::Validator -> CPAN-Meta
+# r: Config::INI::Reader -> Config-INI
+# r: Config::MVP::Assembler -> Config-MVP
+# r: Config::MVP::Assembler::WithBundles -> Config-MVP
+# r: Config::MVP::Reader -> Config-MVP
+# r: Config::MVP::Reader::Findable::ByExtension -> Config-MVP 1.101450
+# r: Config::MVP::Reader::Finder -> Config-MVP 0.092990
+# r: Config::MVP::Section -> Config-MVP
+# r: List::Util -> Scalar-List-Utils
+# r: Mixin::Linewise::Readers -> Mixin-Linewise
+# r: Moose::Role -> Moose
+# r: Moose::Util::TypeConstraints -> Moose
+# r: MooseX::Types::Moose -> MooseX-Types
+# r: PPI::Document -> PPI
+# r: Scalar::Util -> Scalar-List-Utils
+# r: Software::LicenseUtils -> Software-License
+# r: Sub::Exporter::Util -> Sub-Exporter
+# r: Term::ReadKey -> TermReadKey
+# r: Text::Template -> text-template
+# r: strict, warnings -> perl
+
+# NB: PPI::XS is suggested by Dist-Zilla, but upstream of
+# PPI say PPI::XS presently doesn't do anything useful,
+# so the optional useflag and the dependency are skipped.
+RDEPEND="
+ ${X_BREAKS}
+ !minimal? (
+ >=dev-perl/Archive-Tar-Wrapper-0.150.0
+ >=dev-perl/Data-OptList-0.110.0
+ dev-perl/Term-ReadLine-Gnu
+ )
+ >=dev-perl/App-Cmd-0.330.0
+ virtual/perl-Archive-Tar
+ >=virtual/perl-CPAN-Meta-2.142.60
+ >=virtual/perl-CPAN-Meta-Requirements-2.121.0
+ >=dev-perl/CPAN-Uploader-0.103.4
+ virtual/perl-Carp
+ >=dev-perl/Class-Load-0.170.0
+ dev-perl/Config-INI
+ >=dev-perl/Config-MVP-2.200.11
+ >=dev-perl/Config-MVP-Reader-INI-2.101.461
+ virtual/perl-Data-Dumper
+ >=dev-perl/Data-Section-0.200.2
+ >=dev-perl/DateTime-0.440.0
+ virtual/perl-Digest-MD5
+ virtual/perl-Encode
+ >=virtual/perl-ExtUtils-Manifest-1.660.0
+ >=dev-perl/File-Copy-Recursive-0.410.0
+ dev-perl/File-Find-Rule
+ virtual/perl-File-Path
+ dev-perl/File-ShareDir
+ >=dev-perl/File-ShareDir-Install-0.30.0
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/File-pushd
+ dev-perl/JSON-MaybeXS
+ >=dev-perl/Log-Dispatchouli-1.102.220
+ >=dev-perl/Mixin-Linewise-0.100.0
+ virtual/perl-Module-CoreList
+ dev-perl/Module-Runtime
+ >=dev-perl/Moose-0.920.0
+ dev-perl/MooseX-LazyRequire
+ >=dev-perl/MooseX-Role-Parameterized-1.10.0
+ dev-perl/MooseX-SetOnce
+ dev-perl/MooseX-Types
+ dev-perl/MooseX-Types-Perl
+ dev-perl/PPI
+ dev-perl/Params-Util
+ >=dev-perl/Path-Tiny-0.52.0
+ >=dev-perl/Perl-PrereqScanner-1.16.0
+ virtual/perl-Pod-Simple
+ >=virtual/perl-Scalar-List-Utils-1.450.0
+ >=dev-perl/Software-License-0.103.14
+ virtual/perl-Storable
+ >=dev-perl/String-Formatter-0.100.680
+ >=dev-perl/String-RewritePrefix-0.6.0
+ dev-perl/Sub-Exporter
+ dev-perl/Sub-Exporter-ForMethods
+ dev-perl/Term-Encoding
+ dev-perl/TermReadKey
+ virtual/perl-Term-ReadLine
+ dev-perl/Term-UI
+ dev-perl/Test-Deep
+ >=dev-perl/Text-Glob-0.80.0
+ dev-perl/Text-Template
+ dev-perl/Try-Tiny
+ dev-perl/YAML-Tiny
+ virtual/perl-autodie
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+ virtual/perl-version
+"
+# t: Software::License::None -> Software-License 0.016
+# t: lib, utf8 -> perl
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/File-ShareDir-Install-0.60.0
+ test? (
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ dev-perl/Test-FailWarnings
+ dev-perl/Test-Fatal
+ dev-perl/Test-File-ShareDir
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-6.015-authordeps-missing.patch"
+)
+src_test() {
+ TZ=UTC perl-module_src_test
+}
diff --git a/dev-perl/Dist-Zilla/Dist-Zilla-6.15.0.ebuild b/dev-perl/Dist-Zilla/Dist-Zilla-6.15.0.ebuild
new file mode 100644
index 000000000000..f96f2921b33a
--- /dev/null
+++ b/dev-perl/Dist-Zilla/Dist-Zilla-6.15.0.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=6.015
+inherit perl-module
+
+DESCRIPTION="distribution builder; installer not included!"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+## CPAN->Gentoo resolution map for grepping in case upstream split a dep
+# breaks: Dist::Zilla::App::Command::stale -> Dist-Zilla-Plugin-PromptIfStale
+# DZA:Command::xtest -> DZP:CheckExtraTests
+# DZP:Author::Plicease::Tests -> DZPB::Author::Plicease
+X_BREAKS="
+ !<dev-perl/Dist-Zilla-Plugin-PromptIfStale-0.40.0
+ !<=dev-perl/Dist-Zilla-App-Command-update-0.40.0
+ !<dev-perl/Dist-Zilla-Plugin-CheckExtraTests-0.29.0
+ !<=dev-perl/Dist-Zilla-PluginBundle-Author-Plicease-2.20.0
+ !<dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild-0.161.230
+ !<=dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild-Filtered-0.1.0
+ !<=dev-perl/Dist-Zilla-Plugin-Git-2.36.0
+ !<=dev-perl/Dist-Zilla-Plugin-Keywords-0.6.0
+ !<dev-perl/Dist-Zilla-Plugin-MakeMaker-Awesome-0.220.0
+ !<=dev-perl/Dist-Zilla-Plugin-NameFromDirectory-0.30.0
+ !<=dev-perl/Dist-Zilla-Plugin-PodWeaver-4.6.0
+ !<=dev-perl/Dist-Zilla-Plugin-Prereqs-AuthorDeps-0.5.0
+ !<dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod-0.161.170
+ !<=dev-perl/Dist-Zilla-Plugin-Run-0.35.0
+ !<=dev-perl/Dist-Zilla-Plugin-Test-CheckDeps-0.13.0
+ !<=dev-perl/Dist-Zilla-Plugin-Test-Version-1.50.0
+ !<=dev-perl/Dist-Zilla-Plugin-TrialVersionComment-0.3.0
+"
+# r: App::Cmd::Command::version -> App-Cmd-0.321
+# r: App::Cmd::Setup -> App-Cmd
+# r: App::Cmd::Tester -> App-Cmd
+# r: App::Cmd::Tester::CaptureExternal -> App-Cmd 0.314
+# r: CPAN::Meta::Converter -> CPAN-Meta
+# r: CPAN::Meta::Merge -> CPAN-Meta 2.142060
+# r: CPAN::Meta::Prereqs -> CPAN-Meta
+# r: CPAN::Meta::Validator -> CPAN-Meta
+# r: Config::INI::Reader -> Config-INI
+# r: Config::MVP::Assembler -> Config-MVP
+# r: Config::MVP::Assembler::WithBundles -> Config-MVP
+# r: Config::MVP::Reader -> Config-MVP
+# r: Config::MVP::Reader::Findable::ByExtension -> Config-MVP 1.101450
+# r: Config::MVP::Reader::Finder -> Config-MVP 0.092990
+# r: Config::MVP::Section -> Config-MVP
+# r: List::Util -> Scalar-List-Utils
+# r: Mixin::Linewise::Readers -> Mixin-Linewise
+# r: Moose::Role -> Moose
+# r: Moose::Util::TypeConstraints -> Moose
+# r: MooseX::Types::Moose -> MooseX-Types
+# r: PPI::Document -> PPI
+# r: Scalar::Util -> Scalar-List-Utils
+# r: Software::LicenseUtils -> Software-License
+# r: Sub::Exporter::Util -> Sub-Exporter
+# r: Term::ReadKey -> TermReadKey
+# r: Text::Template -> text-template
+# r: strict, warnings -> perl
+
+# NB: PPI::XS is suggested by Dist-Zilla, but upstream of
+# PPI say PPI::XS presently doesn't do anything useful,
+# so the optional useflag and the dependency are skipped.
+RDEPEND="
+ ${X_BREAKS}
+ !minimal? (
+ >=dev-perl/Archive-Tar-Wrapper-0.150.0
+ >=dev-perl/Data-OptList-0.110.0
+ dev-perl/Term-ReadLine-Gnu
+ )
+ >=dev-perl/App-Cmd-0.330.0
+ virtual/perl-Archive-Tar
+ >=virtual/perl-CPAN-Meta-2.142.60
+ >=virtual/perl-CPAN-Meta-Requirements-2.121.0
+ >=dev-perl/CPAN-Uploader-0.103.4
+ virtual/perl-Carp
+ >=dev-perl/Class-Load-0.170.0
+ dev-perl/Config-INI
+ >=dev-perl/Config-MVP-2.200.11
+ >=dev-perl/Config-MVP-Reader-INI-2.101.461
+ virtual/perl-Data-Dumper
+ >=dev-perl/Data-Section-0.200.2
+ >=dev-perl/DateTime-0.440.0
+ virtual/perl-Digest-MD5
+ virtual/perl-Encode
+ >=virtual/perl-ExtUtils-Manifest-1.660.0
+ >=dev-perl/File-Copy-Recursive-0.410.0
+ dev-perl/File-Find-Rule
+ virtual/perl-File-Path
+ dev-perl/File-ShareDir
+ >=dev-perl/File-ShareDir-Install-0.30.0
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/File-pushd
+ dev-perl/JSON-MaybeXS
+ >=dev-perl/Log-Dispatchouli-1.102.220
+ >=dev-perl/Mixin-Linewise-0.100.0
+ virtual/perl-Module-CoreList
+ dev-perl/Module-Runtime
+ >=dev-perl/Moose-0.920.0
+ dev-perl/MooseX-LazyRequire
+ >=dev-perl/MooseX-Role-Parameterized-1.10.0
+ dev-perl/MooseX-SetOnce
+ dev-perl/MooseX-Types
+ dev-perl/MooseX-Types-Perl
+ dev-perl/PPI
+ dev-perl/Params-Util
+ >=dev-perl/Path-Tiny-0.52.0
+ >=dev-perl/Perl-PrereqScanner-1.16.0
+ virtual/perl-Pod-Simple
+ >=virtual/perl-Scalar-List-Utils-1.450.0
+ >=dev-perl/Software-License-0.103.14
+ virtual/perl-Storable
+ >=dev-perl/String-Formatter-0.100.680
+ >=dev-perl/String-RewritePrefix-0.6.0
+ dev-perl/Sub-Exporter
+ dev-perl/Sub-Exporter-ForMethods
+ dev-perl/Term-Encoding
+ dev-perl/TermReadKey
+ virtual/perl-Term-ReadLine
+ dev-perl/Term-UI
+ dev-perl/Test-Deep
+ >=dev-perl/Text-Glob-0.80.0
+ dev-perl/Text-Template
+ dev-perl/Try-Tiny
+ dev-perl/YAML-Tiny
+ virtual/perl-autodie
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+ virtual/perl-version
+"
+# t: Software::License::None -> Software-License 0.016
+# t: lib, utf8 -> perl
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/File-ShareDir-Install-0.60.0
+ test? (
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ dev-perl/Test-FailWarnings
+ dev-perl/Test-Fatal
+ dev-perl/Test-File-ShareDir
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+src_test() {
+ TZ=UTC perl-module_src_test
+}
diff --git a/dev-perl/Dist-Zilla/Manifest b/dev-perl/Dist-Zilla/Manifest
index 149e60b05a9b..742250ed37b0 100644
--- a/dev-perl/Dist-Zilla/Manifest
+++ b/dev-perl/Dist-Zilla/Manifest
@@ -1,4 +1,8 @@
+AUX Dist-Zilla-6.015-authordeps-missing.patch 1378 BLAKE2B 4666036c22cb9c2cb869541560b9c16b2c259bedd3a43314e13ed1c4ba7d15dbb9729451e33982c6b78da1c5a03c99e304d7f8ea8759279255af117c3e9258da SHA512 1abd7648457e0d52782bfb9ac7636b07cf725e2328b08a059a19d297b9865a0c06ef287b45f871401bdf39e93b5cbc4f42d8a1aafa8e38ce617112b23d49e4f9
AUX Dist-Zilla-6.10.0-perl526.patch 1963 BLAKE2B 23237b2231fa160beca39c06d15bd82148476c2b3c44bdf7509fcd7c52931aeda4300bbc64c4f50257f26a8323f4ec0fa824e15a78853455a980c22ef23f2cee SHA512 bc2058c71160be5cd191e46e19d245070d2f4f12bc2f067c702757e30394aa1bc986d055f40303716e3da85bc48e40c31683cf21bf495da634f983227c20baa7
DIST Dist-Zilla-6.010.tar.gz 198805 BLAKE2B 82c5792f81174d74cd917e77f9e3899d0fc8233b6a36147618cd324dfc672c47e91305b2e5335a376846a8f25a5ab1b6d10c5ce1e11def5eb17a7af88d03e12e SHA512 707a736c43b1a52038a01c2e238ac39fa35c5eb7120c7fa11a06248f5fc3518c5c75e3660553058085c5b930e6df6cebfd1957435b78ae48f8b4d45d3b99300f
+DIST Dist-Zilla-6.015.tar.gz 202822 BLAKE2B e26d50d7cf90940e3e003f1d056885481878aec8a2b16ed8413c237aeafb878bc002ee231a0edbdc4b5fd584480f1b245b3469a27a2c5edc93fd79a57de96dcf SHA512 956a32d2123fa371f2589f2d18d87b6408fd13ebdf0e711da4cac8ebc3dd82accf9e97d6dd577d69bf795c589b7246b9f9f1124835a6dcdb89730fdeec547715
EBUILD Dist-Zilla-6.10.0-r2.ebuild 5090 BLAKE2B 5652bd38017e7257a2c6793a8843375871ec9830019c60c5a61c5dabe8568c94b7832ad87a9bc5a07ba4a1a42d0d1b6d221dd0ea5ad8f8ae74df2e71d4a533f2 SHA512 8ef90ae082eeabc52d2dd8d32121f423594a4be7d61ddf055dddde15c6d25a67986f406d0fde283732f841179c0eef2174191badaff131819128877ea5584514
+EBUILD Dist-Zilla-6.15.0-r1.ebuild 5086 BLAKE2B 2283b7e2fa7eb3d2e0a507795281612ff5f53158e07dd6ca2a71efcc23bd9cb7302ec14ce336c5500e5a48893e6208edb62f65b8b1f258a2ea6ec1ef631ce2fc SHA512 fe56e9bd3d41d3a92a1d58318adc4e36e7d2687d59e76b3afe06cb482863bb28c4e3b3beb71119c763873ae1ab29fb502b18732381fb8cb3e766b389be45e70d
+EBUILD Dist-Zilla-6.15.0.ebuild 5022 BLAKE2B 009794e51cc27c0dc1575d31e4e0899b3f14281834d0c84e47b4af294d20addbac1596abf0fed05028aaa2a0fd8f301360ff6ef116954ad81dce7d9e7f24175e SHA512 b79007778dbfd17edd877c204c93a49ee24a1d7dc6a97a3d27cc279fa4964b21f71106083a1844d0c526a2f4e440935cfada4ad8e9bd30c33390b6db6ee769c5
MISC metadata.xml 11020 BLAKE2B 583f3f8c1e23b7ab140c69e3b1beb6d95cea0a88499735f5ded96a97532da6692efe11f0cb0247ba2ebb7529eef31f99a842a03be3083c078b1f059065dfe460 SHA512 e4fb36dd97e7e8d984a9eea534b194df7943458525a893f236396ca6bc2e361aebd4d977a48602126c166a111fc0b1f70e3eeeef55c1029a504c2c201abaf178
diff --git a/dev-perl/Dist-Zilla/files/Dist-Zilla-6.015-authordeps-missing.patch b/dev-perl/Dist-Zilla/files/Dist-Zilla-6.015-authordeps-missing.patch
new file mode 100644
index 000000000000..c9e25ebff619
--- /dev/null
+++ b/dev-perl/Dist-Zilla/files/Dist-Zilla-6.015-authordeps-missing.patch
@@ -0,0 +1,36 @@
+From 21a92b08d30cd4758fefe1706eb96af30082cb7b Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 8 Aug 2020 05:25:21 +1200
+Subject: Fix INC traversal breakage with non-string objects in INC
+
+As `$root` is a Path object, and because there are defined mechanisms
+for handling objects in `@INC` traversal, this object being added to
+`@INC` can cause panics when the perl interpreter tries to call a method
+that doesn't exist, violating the API.
+
+And this in turn makes various authordeps appear missing when they're
+present, due to suppression of the error occurring from the above.
+
+Forcing stringification of the path object mitigates this issue.
+
+Bug: https://github.com/rjbs/Dist-Zilla/issues/660
+---
+ lib/Dist/Zilla/Util/AuthorDeps.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Dist/Zilla/Util/AuthorDeps.pm b/lib/Dist/Zilla/Util/AuthorDeps.pm
+index cbca1c7..603d67b 100644
+--- a/lib/Dist/Zilla/Util/AuthorDeps.pm
++++ b/lib/Dist/Zilla/Util/AuthorDeps.pm
+@@ -113,7 +113,7 @@ sub extract_author_deps {
+ : do {
+ my $m = $_;
+ ! eval {
+- local @INC = @INC; push @INC, $root;
++ local @INC = @INC; push @INC, "$root";
+ # This will die if module is missing
+ Module::Runtime::require_module($m);
+ my $v = $vermap->{$m};
+--
+2.28.0
+