summaryrefslogtreecommitdiff
path: root/dev-perl/Digest-GOST
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Digest-GOST
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Digest-GOST')
-rw-r--r--dev-perl/Digest-GOST/Digest-GOST-0.60.0-r1.ebuild26
-rw-r--r--dev-perl/Digest-GOST/Manifest4
-rw-r--r--dev-perl/Digest-GOST/files/Digest-GOST-0.60.0-bigendian-link.patch43
-rw-r--r--dev-perl/Digest-GOST/metadata.xml13
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-perl/Digest-GOST/Digest-GOST-0.60.0-r1.ebuild b/dev-perl/Digest-GOST/Digest-GOST-0.60.0-r1.ebuild
new file mode 100644
index 000000000000..1486cc65a5bb
--- /dev/null
+++ b/dev-perl/Digest-GOST/Digest-GOST-0.60.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRAY
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Perl interface to the GOST R 34.11-94 digest algorithm"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Digest
+ virtual/perl-XSLoader
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.820.0
+ )
+"
+PATCHES=( "${FILESDIR}/${P}-bigendian-link.patch" )
diff --git a/dev-perl/Digest-GOST/Manifest b/dev-perl/Digest-GOST/Manifest
new file mode 100644
index 000000000000..82ae31f89996
--- /dev/null
+++ b/dev-perl/Digest-GOST/Manifest
@@ -0,0 +1,4 @@
+AUX Digest-GOST-0.60.0-bigendian-link.patch 1314 BLAKE2B 09ffd9e6303dd225cd052e4cfd6568ba1991b5db120db73e939d175e679b613c8e7ae22961b9a7c29348fe6dda97d9eb7e821f5b115564f86096a08fc39c925e SHA512 f3f755e4ae385f35b89c0fdd8934f6df4ecb83af0f8e35af84cd9a081e1d9edfbe5b41d257006bec93569e15601fd6bacd0a877738e04a48d425c2b2cb2427c4
+DIST Digest-GOST-0.06.tar.gz 39496 BLAKE2B b2495701373011fcdf9e0076dc51a2429f190252b772e5a9ee97d1d2286986eac50e5d6c4b5f5d03567f62bd7153264c56ef4f18ad33b655f11f38ccd181678a SHA512 7df9e5ce9cdc72da417207d197ae41e80ff4405d5fef1f6279a6043708b7688f4ca25c9d634b83a93be633b3ce7e672f6a697bfcc5ffa956379f9375f995e94e
+EBUILD Digest-GOST-0.60.0-r1.ebuild 558 BLAKE2B e241934c28741cbd9655868e132e2430c5057cae69258d6fd39f79c1c357f474c445bb8454ee4c0a3854df0cb66bc831ebb5af493c460cf67e7da604ea6ed7e9 SHA512 a26ad0a0411ca656be5ddd1d39f05931da928d3ed4e1099a6d6d6de8418aa4b3ed02a1da6ec39219ab9fdb407cf4dd63e52e9e930a6c88e874476bb7ceec2e27
+MISC metadata.xml 464 BLAKE2B c3e9194f35f644fb250541f8faf34c3711d0a13bd1ed8854a94ce28b3e29a534253027fa8af57e780ab66232f0cca9c0760927b047481063e347f5f58b670dd3 SHA512 a2f394c73a87325c515b5d2420d85b300e6619d53962f0f68a9ffbbc4e610d281eac1a0d071a5917eadb7361ca9d0886db43f3c8efd3a6cdd9cc43f3c6e83eda
diff --git a/dev-perl/Digest-GOST/files/Digest-GOST-0.60.0-bigendian-link.patch b/dev-perl/Digest-GOST/files/Digest-GOST-0.60.0-bigendian-link.patch
new file mode 100644
index 000000000000..bc43f7e079a5
--- /dev/null
+++ b/dev-perl/Digest-GOST/files/Digest-GOST-0.60.0-bigendian-link.patch
@@ -0,0 +1,43 @@
+From c7dda2667b15cb9cf44856bd0d8efc9321eca354 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Mon, 16 Oct 2017 10:27:32 +0100
+Subject: Fix link failure on big-endian platforms.
+
+On powerpc64 tests failed as:
+
+```
+ Failed 2/2 subtests
+ ===( 2;0 0/? 0/? 0/? )=========================================Can't load '.../Digest-GOST-0.06/blib/arch/auto/Digest/GOST/GOST.so' for
+ module Digest::GOST: .../Digest-GOST-0.06/blib/arch/auto/Digest/GOST/GOST.so: undefined symbol: rhash_u32_swap_copy at /usr/lib64/perl5/5.24.3/powerpc64-linux/DynaLoader.pm line 193.
+```
+
+rhash_u32_swap_copy() is a function local to this package.
+Seems to be used only for big-endian case.
+
+The fix is to add missing 'src/byte_order.c' file.
+
+All tests pass with patch applied.
+
+Bug: https://bugs.gentoo.org/608214
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=120092
+Bug: https://github.com/gray/digest-gost/pull/1
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ GOST.xs | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/GOST.xs b/GOST.xs
+index 1dfd33c..4ea6f35 100644
+--- a/GOST.xs
++++ b/GOST.xs
+@@ -6,6 +6,7 @@
+ #include "ppport.h"
+
+ #include "src/gost.c"
++#include "src/byte_order.c"
+
+ static int
+ hex_encode (char *dest, const unsigned char *src, int len) {
+--
+2.14.2
+
diff --git a/dev-perl/Digest-GOST/metadata.xml b/dev-perl/Digest-GOST/metadata.xml
new file mode 100644
index 000000000000..f017bb0acc4d
--- /dev/null
+++ b/dev-perl/Digest-GOST/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Digest-GOST</remote-id>
+ <remote-id type="cpan-module">Digest::GOST</remote-id>
+ <remote-id type="cpan-module">Digest::GOST::CryptoPro</remote-id>
+ </upstream>
+</pkgmetadata>