summaryrefslogtreecommitdiff
path: root/dev-perl/DateTime-Format-Flexible
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/DateTime-Format-Flexible
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/DateTime-Format-Flexible')
-rw-r--r--dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild34
-rw-r--r--dev-perl/DateTime-Format-Flexible/Manifest3
-rw-r--r--dev-perl/DateTime-Format-Flexible/metadata.xml16
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild
new file mode 100644
index 000000000000..d14afe324c37
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.280.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=THINC
+DIST_VERSION=0.28
+DIST_EXAMPLES=( "example/*" )
+inherit perl-module
+
+DESCRIPTION="Flexibly parse strings and turn them into DateTime objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/DateTime
+ >=dev-perl/DateTime-Format-Builder-0.740.0
+ dev-perl/DateTime-TimeZone
+ dev-perl/List-MoreUtils
+ dev-perl/Module-Pluggable
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-MockTime
+ >=virtual/perl-Test-Simple-0.440.0
+ )
+"
+src_test() {
+ perl_rm_files t/002_pod.t t/003_podcoverage.t
+ perl-module_src_test
+}
diff --git a/dev-perl/DateTime-Format-Flexible/Manifest b/dev-perl/DateTime-Format-Flexible/Manifest
new file mode 100644
index 000000000000..6ca74389a64a
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/Manifest
@@ -0,0 +1,3 @@
+DIST DateTime-Format-Flexible-0.28.tar.gz 73722 BLAKE2B 38e23f7795ca66154e303eb7260568a27b08af937ffeef2aa61b03a81ad91d55e6a46e08105d564034a8cf02fc00ec87c26ce6510aed76e08ce73d3ec8c16abb SHA512 e74de1cf104a37cf832d5976fd450476a42b945a8fd03ab1ddea504e4041009534cef9e72a75a120ab3ed9a1af63fb05bd5876632b594db9e7f21f419678d2d8
+EBUILD DateTime-Format-Flexible-0.280.0.ebuild 689 BLAKE2B 1662e0954dcb0b6de906f4e8dbf4e901acfa1176c78867b40103cc0e5c26b5f003fc6ea0966da426d80105ec038e07fced736e6db33384295b0d2f58776265ad SHA512 cbfe988712b0c119a758479be1b02482fc1caa53ef248d91c1860d572465cb4eb3632011aa9f30125601e3ea683f48df4cb338efc32d58d37352d231505e0681
+MISC metadata.xml 749 BLAKE2B c7fe8bc9184184a8010220c476c113a28eabcbc90b8a1f58d13fc17650b92dc954470c1edeaebbdb8b7cb10cccb39838bef9ee859d191e53455755730e2c0413 SHA512 14511113c46b25b011aec9c24c2b370807bdcd308104e0b37a79a1341b88f60e40c803a30c5d4597a0e22ef5e79915b72bfe6a420b4cd4268650d625249ba9e6
diff --git a/dev-perl/DateTime-Format-Flexible/metadata.xml b/dev-perl/DateTime-Format-Flexible/metadata.xml
new file mode 100644
index 000000000000..f1c0ecce20fa
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">DateTime-Format-Flexible</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang::de</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang::en</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang::es</remote-id>
+ </upstream>
+</pkgmetadata>