summaryrefslogtreecommitdiff
path: root/dev-perl/DBIx-Migration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/DBIx-Migration
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/DBIx-Migration')
-rw-r--r--dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild31
-rw-r--r--dev-perl/DBIx-Migration/Manifest3
-rw-r--r--dev-perl/DBIx-Migration/metadata.xml12
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild b/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild
new file mode 100644
index 000000000000..be3fe153f178
--- /dev/null
+++ b/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DANIEL
+MODULE_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Seamless DB schema up- and downgrades"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/File-Slurp
+ virtual/perl-File-Spec
+ dev-perl/DBI
+ dev-perl/Class-Accessor"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/DBD-SQLite
+ )"
+
+SRC_TEST=do
+
+src_prepare() {
+ use test && perl_rm_files t/02pod.t t/03podcoverage.t
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBIx-Migration/Manifest b/dev-perl/DBIx-Migration/Manifest
new file mode 100644
index 000000000000..c79c3ab87566
--- /dev/null
+++ b/dev-perl/DBIx-Migration/Manifest
@@ -0,0 +1,3 @@
+DIST DBIx-Migration-0.07.tar.gz 5602 BLAKE2B e0119acd21c08374deaa73f8633b0b04e316779c82113ce53003e57ad3ffd7da4635b7e530bdec9772cab5bb97077d22ef08a1ae9f49cb4166dd8afe94917ad9 SHA512 8a63e7d5a7c6306920185792cb71513c823756f8c541d77a585551e9325eb3a4e6c7f8bbaf34a9091727dd32d1ff81fb69ec6317b644d7df555461ceba57d4f8
+EBUILD DBIx-Migration-0.70.0.ebuild 558 BLAKE2B f96f1907fa0671604f8a5e196fa351f22d16b1b829cb6d3ad90329d9429614e65b5b3712c3301eec799664f4808b7b8097729237e334b8ebcfb371d3dc4c3dc5 SHA512 7be58684fa352e52ad2e65c2101382dd3424acd417d6ffb4e1fa6f77eba6d1e7bb4baa2bfd997456120e4d0e14058f1a289e1b2be252ed89db8ff507d8060499
+MISC metadata.xml 400 BLAKE2B 919be0a48c628d84c947692144d67552fd70731b5d3a30209d8ebe8bc5e6ab5f43fdaf3058a02ee33480a375169b5f57f450263a3e1d7bba8c0637c7e43006c4 SHA512 e802fdfc7021fd0b0ddadb753fb8881754c267dc6f0c55e3b39a77ea02cbfa718fe37003c269d0cbe39bb7817f8ccf800fc722f63775ab5e3c82c4a67d3b1e40
diff --git a/dev-perl/DBIx-Migration/metadata.xml b/dev-perl/DBIx-Migration/metadata.xml
new file mode 100644
index 000000000000..6ffdfe0f7c20
--- /dev/null
+++ b/dev-perl/DBIx-Migration/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">DBIx-Migration</remote-id>
+ <remote-id type="cpan-module">DBIx::Migration</remote-id>
+ </upstream>
+</pkgmetadata>