summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild
new file mode 100644
index 000000000000..5468e3cab0b2
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AMS
+DIST_VERSION=2.18
+inherit perl-module
+
+DESCRIPTION="The Twofish Encryption Algorithm"
+
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.180.0-configure-clang16.patch
+)
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}