summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-SSLeay/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Crypt-SSLeay/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Crypt-SSLeay/files')
-rw-r--r--dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch27
-rw-r--r--dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch40
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch
new file mode 100644
index 000000000000..9ea1c6b8f6dd
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-dot-inc.patch
@@ -0,0 +1,27 @@
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Tue, 20 Jun 2017 08:04:39 +1200
+Subject: [PATCH] Remove need for '.' in @INC
+
+https://github.com/nanis/Crypt-SSLeay/pull/7
+
+---
+ Makefile.PL | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index fcc3a7d..937789a 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -8,7 +8,8 @@ use Getopt::Long qw( GetOptionsFromArray );
+ use Path::Class;
+ use Try::Tiny;
+
+-use inc::IO::Interactive::Tiny;
++use lib 'inc';
++use IO::Interactive::Tiny;
+
+ caller
+ or run(\@ARGV, [qw{ssl crypto ssl32 ssleay32 eay32 libeay32 z}]);
+--
+2.13.1
+
diff --git a/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch
new file mode 100644
index 000000000000..72febbfff7e9
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch
@@ -0,0 +1,40 @@
+--- a/SSLeay.xs 2014-04-24 07:36:24.000000000 +0000
++++ b/SSLeay.xs 2015-12-27 13:39:05.695422091 +0000
+@@ -45,13 +45,6 @@
+ }
+ #endif
+
+-
+-#if SSLEAY_VERSION_NUMBER >= 0x0900
+-#define CRYPT_SSL_CLIENT_METHOD SSLv3_client_method()
+-#else
+-#define CRYPT_SSL_CLIENT_METHOD SSLv2_client_method()
+-#endif
+-
+ static void InfoCallback(const SSL *s,int where,int ret)
+ {
+ const char *str;
+@@ -145,22 +138,7 @@
+ RAND_seed(buf, CRYPT_SSLEAY_RAND_BUFSIZE);
+ }
+
+- if(ssl_version == 23) {
+- ctx = SSL_CTX_new(SSLv23_client_method());
+- }
+- else if(ssl_version == 3) {
+- ctx = SSL_CTX_new(SSLv3_client_method());
+- }
+- else {
+-#ifndef OPENSSL_NO_SSL2
+- /* v2 is the default */
+- ctx = SSL_CTX_new(SSLv2_client_method());
+-#else
+- /* v3 is the default */
+- ctx = SSL_CTX_new(SSLv3_client_method());
+-#endif
+- }
+-
++ ctx = SSL_CTX_new(SSLv23_client_method());
+ SSL_CTX_set_options(ctx,SSL_OP_ALL|0);
+ SSL_CTX_set_default_verify_paths(ctx);
+ SSL_CTX_set_verify(ctx, SSL_VERIFY_NONE, NULL);