summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0-r1.ebuild
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0-r1.ebuild b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0-r1.ebuild
new file mode 100644
index 000000000000..f7a56171e9d8
--- /dev/null
+++ b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.250.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MIKAGE
+DIST_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="S/MIME message signing, verification, encryption and decryption"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.9:0 )
+ libressl? ( dev-libs/libressl )
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/ExtUtils-CChecker
+ >=virtual/perl-ExtUtils-Constant-0.230.0
+ test? (
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ !minimal? (
+ >=dev-perl/Test-Taint-1.60.0
+ >=dev-perl/Taint-Util-0.80.0
+ )
+ )
+"
+PERL_RM_FILES=(
+ t/boilerplate.t
+ t/manifest.t
+ t/dependencies.t
+ t/pod-coverage.t
+ t/pod.t
+)
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}