summaryrefslogtreecommitdiff
path: root/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild')
-rw-r--r--dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild b/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild
new file mode 100644
index 000000000000..469ab38663d1
--- /dev/null
+++ b/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=BTROTT
+MODULE_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Read/write encrypted ASN.1 PEM files"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Class-ErrorHandler
+ dev-perl/Convert-ASN1
+ dev-perl/Crypt-DES_EDE3
+ virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-526.patch"
+ "${FILESDIR}/${P}-decryptiontest.patch"
+ "${FILESDIR}/${P}-testbuilder.patch"
+)
+
+SRC_TEST=do