summaryrefslogtreecommitdiff
path: root/dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild')
-rw-r--r--dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild b/dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild
new file mode 100644
index 000000000000..7e5bdc1339d8
--- /dev/null
+++ b/dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.20
+inherit perl-module
+
+DESCRIPTION="A working (require q{Class::Name}) and more"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Data-OptList
+ >=dev-perl/Module-Runtime-0.12.0
+ >=dev-perl/Module-Implementation-0.40.0
+ >=dev-perl/Package-Stash-0.320.0
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ )"
+
+SRC_TEST="do"