summaryrefslogtreecommitdiff
path: root/dev-perl/Class-Container/Class-Container-0.130.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-perl/Class-Container/Class-Container-0.130.0.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-perl/Class-Container/Class-Container-0.130.0.ebuild')
-rw-r--r--dev-perl/Class-Container/Class-Container-0.130.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Class-Container/Class-Container-0.130.0.ebuild b/dev-perl/Class-Container/Class-Container-0.130.0.ebuild
new file mode 100644
index 000000000000..6ca9808b5759
--- /dev/null
+++ b/dev-perl/Class-Container/Class-Container-0.130.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="Glue object frameworks together transparently"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Params-Validate-0.24-r1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ >=dev-perl/Module-Build-0.360.100
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test
+ )
+"
+PERL_RM_FILES=(
+ "t/author-critic.t"
+)