summaryrefslogtreecommitdiff
path: root/dev-perl/CGI/CGI-4.600.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
commitaafdd1dcd9a66da0b1bcdfadbca62add48751897 (patch)
treed328a4fe625235ee8ea443c3b1bec1fd105af11d /dev-perl/CGI/CGI-4.600.0.ebuild
parente0345ef79b0b4a444151748ce1f5364fc2dd147b (diff)
gentoo auto-resync : 13:11:2023 - 10:28:51
Diffstat (limited to 'dev-perl/CGI/CGI-4.600.0.ebuild')
-rw-r--r--dev-perl/CGI/CGI-4.600.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-4.600.0.ebuild b/dev-perl/CGI/CGI-4.600.0.ebuild
new file mode 100644
index 000000000000..0926178cd946
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.600.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=LEEJO
+DIST_VERSION=4.60
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-File-Temp-0.170.0
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ dev-perl/Test-NoWarnings
+ >=virtual/perl-Test-Simple-0.980.0
+ >=dev-perl/Test-Warn-0.300.0
+ )
+"
+
+PERL_RM_FILES=( "t/compiles_pod.t" "t/changes.t" )