summaryrefslogtreecommitdiff
path: root/dev-perl/CGI/CGI-4.380.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-perl/CGI/CGI-4.380.0.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-perl/CGI/CGI-4.380.0.ebuild')
-rw-r--r--dev-perl/CGI/CGI-4.380.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-4.380.0.ebuild b/dev-perl/CGI/CGI-4.380.0.ebuild
new file mode 100644
index 000000000000..fafd5765e7b9
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.380.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LEEJO
+DIST_VERSION=4.38
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-File-Temp-0.170.0
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ >=dev-perl/Test-Deep-0.110.0
+ dev-perl/Test-NoWarnings
+ >=virtual/perl-Test-Simple-0.980.0
+ >=dev-perl/Test-Warn-0.300.0
+ )
+"
+PERL_RM_FILES=( "t/compiles_pod.t" "t/changes.t" )