summaryrefslogtreecommitdiff
path: root/dev-perl/CGI/CGI-4.310.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/CGI/CGI-4.310.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/CGI/CGI-4.310.0.ebuild')
-rw-r--r--dev-perl/CGI/CGI-4.310.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-4.310.0.ebuild b/dev-perl/CGI/CGI-4.310.0.ebuild
new file mode 100644
index 000000000000..41b27a17b7c4
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.310.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LEEJO
+DIST_VERSION=4.31
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-File-Temp-0.170.0
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.980.0
+ >=dev-perl/Test-Deep-0.110.0
+ >=dev-perl/Test-Warn-0.300.0
+ )
+"
+
+src_test() {
+ perl_rm_files t/compiles_pod.t t/changes.t
+ perl-module_src_test
+}