summaryrefslogtreecommitdiff
path: root/dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild')
-rw-r--r--dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild b/dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild
new file mode 100644
index 000000000000..22ed9f1ea5ca
--- /dev/null
+++ b/dev-perl/Business-ISSN/Business-ISSN-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=1.004
+inherit perl-module
+
+DESCRIPTION="Object and functions to work with International Standard Serial Numbers"
+LICENSE="Artistic-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ virtual/perl-File-Spec
+ test? (
+ >=virtual/perl-Test-Simple-1.0.0
+ )
+"
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod_coverage.t"
+ "t/test_manifest"
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-1.003-no-test-manifest.patch"
+)