summaryrefslogtreecommitdiff
path: root/dev-perl/BZ-Client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/BZ-Client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/BZ-Client')
-rw-r--r--dev-perl/BZ-Client/BZ-Client-4.400.200.ebuild50
-rw-r--r--dev-perl/BZ-Client/Manifest3
-rw-r--r--dev-perl/BZ-Client/metadata.xml37
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-perl/BZ-Client/BZ-Client-4.400.200.ebuild b/dev-perl/BZ-Client/BZ-Client-4.400.200.ebuild
new file mode 100644
index 000000000000..6bd78c8b5fd8
--- /dev/null
+++ b/dev-perl/BZ-Client/BZ-Client-4.400.200.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DJZORT
+DIST_VERSION=4.4002
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="A client for the Bugzilla web services API."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/DateTime-Format-Strptime
+ dev-perl/DateTime-TimeZone
+ virtual/perl-Encode
+ virtual/perl-File-Spec
+ dev-perl/HTTP-CookieJar
+ virtual/perl-HTTP-Tiny
+ virtual/perl-MIME-Base64
+ dev-perl/URI
+ dev-perl/XML-Parser
+ dev-perl/XML-Writer
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ dev-perl/Clone
+ virtual/perl-Data-Dumper
+ dev-perl/DateTime
+ dev-perl/IO-Socket-SSL
+ dev-perl/Test-RequiresInternet
+ virtual/perl-Test-Simple
+ dev-perl/Text-Password-Pronounceable
+ )
+"
+
+src_test() {
+ has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}} && export TEST_AUTHOR=1
+ perl_rm_files t/author-* t/release-*
+ perl-module_src_test
+}
diff --git a/dev-perl/BZ-Client/Manifest b/dev-perl/BZ-Client/Manifest
new file mode 100644
index 000000000000..98f814bed314
--- /dev/null
+++ b/dev-perl/BZ-Client/Manifest
@@ -0,0 +1,3 @@
+DIST BZ-Client-4.4002.tar.gz 83998 BLAKE2B 8e18709a8996d036cf64a3f3dd735ed1c0bce00b0ef4e1e930f2d6c09c14fd02b28c92803c98c8d17c27f6287ee03b4b0f9c28df800ed57988d16a1bef570dc9 SHA512 7027554b423c114396d338a6f477f5f8c36077735e3586ee293ce1a4beed189479b9c33554f8af1532e096b5b3b9a0720efbe4390392ebd503af70ce2ec3844d
+EBUILD BZ-Client-4.400.200.ebuild 1095 BLAKE2B 9e1391a989716f20dbfc8dae1fae9572d925122be52c33f795cb5d05ee9612f3b83179b4781290239a9316d7bb037c0d6373368d39c6cf522f684faac83b5831 SHA512 cbfbcee320634386b34274edb05be7236154a09923c79351312c78b9210b7045c88b24cc5ac595ee039e9be6112bbb69312a947c9b647fb9426d3aff90b549e7
+MISC metadata.xml 2122 BLAKE2B 25b3f749e7eebc86ff5fe32e437911a9011ac4da44b3bad40abe592492c7cf175666c821bf173dd232da8d18bccba4279661edbbfcaa7ccc0f1d36b14175238a SHA512 7195f1867e7a121a4faf3a53e4b3696d5c706b68f9d6cde668b082b4e44ea0f90cd8aa675ed1908d29cd64c11ce55ea70884015b6bc775fc4c8eadbc64e2e4c3
diff --git a/dev-perl/BZ-Client/metadata.xml b/dev-perl/BZ-Client/metadata.xml
new file mode 100644
index 000000000000..17fbe93cb021
--- /dev/null
+++ b/dev-perl/BZ-Client/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">BZ-Client</remote-id>
+ <remote-id type="cpan-module">BZ::Client</remote-id>
+ <remote-id type="cpan-module">BZ::Client::API</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bug</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bug::Attachment</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bug::Comment</remote-id>
+ <remote-id type="cpan-module">BZ::Client::BugUserLastVisit</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Bugzilla</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Classification</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Component</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Exception</remote-id>
+ <remote-id type="cpan-module">BZ::Client::FlagType</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Group</remote-id>
+ <remote-id type="cpan-module">BZ::Client::Product</remote-id>
+ <remote-id type="cpan-module">BZ::Client::User</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Array</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Handler</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Parser</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Response</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Struct</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::Value</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::base64</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::boolean</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::double</remote-id>
+ <remote-id type="cpan-module">BZ::Client::XMLRPC::int</remote-id>
+ <remote-id type="github">djzort/BZ-Client</remote-id>
+ </upstream>
+</pkgmetadata>