summaryrefslogtreecommitdiff
path: root/dev-perl/BSON
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/BSON
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/BSON')
-rw-r--r--dev-perl/BSON/BSON-1.4.0.ebuild42
-rw-r--r--dev-perl/BSON/Manifest3
-rw-r--r--dev-perl/BSON/metadata.xml33
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/BSON/BSON-1.4.0.ebuild b/dev-perl/BSON/BSON-1.4.0.ebuild
new file mode 100644
index 000000000000..afe591cc6e61
--- /dev/null
+++ b/dev-perl/BSON/BSON-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MONGODB
+DIST_VERSION=v1.4.0
+inherit perl-module
+
+DESCRIPTION="BSON serialization and deserialization"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Digest-MD5
+ virtual/perl-Exporter
+ virtual/perl-Math-BigInt
+ >=dev-perl/Moo-2.2.4
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Tie-IxHash
+ virtual/perl-Time-HiRes
+ virtual/perl-Time-Local
+ >=dev-perl/boolean-0.450.0
+ dev-perl/namespace-clean
+ virtual/perl-threads-shared
+ virtual/perl-version
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ dev-perl/JSON-MaybeXS
+ >=dev-perl/Path-Tiny-0.54.0
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/BSON/Manifest b/dev-perl/BSON/Manifest
new file mode 100644
index 000000000000..47f31929581f
--- /dev/null
+++ b/dev-perl/BSON/Manifest
@@ -0,0 +1,3 @@
+DIST BSON-v1.4.0.tar.gz 99911 BLAKE2B e993b22721f80b444a701dc5017792b54db475abe53e997baba9314b4c30aca0e8f88173d4caa70bbc07fae8131a5f2618bbcba0f3b27b1578b20447c6f3549f SHA512 3904ad3e426514fc826ef3dea31c93c9ce22e3b0d4b4790528e8eba91412e7dc626b44c08a43fb528780bd53a29d25a5b9ad6fd270cfb52fe8e3fdcbc3ba5afe
+EBUILD BSON-1.4.0.ebuild 908 BLAKE2B d588d419e617681f5fd5b9f10bdfe61a39ab6fa4bfa4825c61f5db1b54cadf5891a7d8a2dc9d476ea01a8680444c5483eba22e8bd6f4525476b48624067be2a6 SHA512 0bcb3fe7bea80a9dd68e18dc09a3dc5d4a468687bedbbd88fbb4e3b5bff99eb3eb517410c8cb793bc0555a377f5c41f37c3149f5892ddfa0459affc8b629f2a0
+MISC metadata.xml 1602 BLAKE2B bb34ef1affffabdc2584fe7ebef86875403d710334c84cf08fb1f19532f83025f83610bf602af9f7915d3a5af4579f31b80cb385dd2cb61d0cd83baca84c9581 SHA512 76e0d3857d36330bd611b5d5583ad22701463680a44283aca2f4594845653f49df5f0551e799eb2dc7ce807a5a23b77e86453f3af0617aa7d5661ada29c5991f
diff --git a/dev-perl/BSON/metadata.xml b/dev-perl/BSON/metadata.xml
new file mode 100644
index 000000000000..d535b9a0609c
--- /dev/null
+++ b/dev-perl/BSON/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">BSON</remote-id>
+ <remote-id type="cpan-module">BSON</remote-id>
+ <remote-id type="cpan-module">BSON::Binary</remote-id>
+ <remote-id type="cpan-module">BSON::Bool</remote-id>
+ <remote-id type="cpan-module">BSON::Bytes</remote-id>
+ <remote-id type="cpan-module">BSON::Code</remote-id>
+ <remote-id type="cpan-module">BSON::DBRef</remote-id>
+ <remote-id type="cpan-module">BSON::Decimal128</remote-id>
+ <remote-id type="cpan-module">BSON::Doc</remote-id>
+ <remote-id type="cpan-module">BSON::Double</remote-id>
+ <remote-id type="cpan-module">BSON::Int32</remote-id>
+ <remote-id type="cpan-module">BSON::Int64</remote-id>
+ <remote-id type="cpan-module">BSON::MaxKey</remote-id>
+ <remote-id type="cpan-module">BSON::MinKey</remote-id>
+ <remote-id type="cpan-module">BSON::OID</remote-id>
+ <remote-id type="cpan-module">BSON::ObjectId</remote-id>
+ <remote-id type="cpan-module">BSON::PP</remote-id>
+ <remote-id type="cpan-module">BSON::Raw</remote-id>
+ <remote-id type="cpan-module">BSON::Regex</remote-id>
+ <remote-id type="cpan-module">BSON::String</remote-id>
+ <remote-id type="cpan-module">BSON::Time</remote-id>
+ <remote-id type="cpan-module">BSON::Timestamp</remote-id>
+ <remote-id type="cpan-module">BSON::Types</remote-id>
+ </upstream>
+</pkgmetadata>