summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild')
-rw-r--r--dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild b/dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild
new file mode 100644
index 000000000000..317928a4f960
--- /dev/null
+++ b/dev-perl/Authen-SASL/Authen-SASL-2.160.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GBARR
+DIST_VERSION=2.16
+inherit perl-module
+
+DESCRIPTION="A Perl SASL interface"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="kerberos test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+ kerberos? ( dev-perl/GSSAPI )
+"
+BDEPEND="${DEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.42
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.16-no-dot-inc.patch"
+)