summaryrefslogtreecommitdiff
path: root/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild')
-rw-r--r--dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild b/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild
new file mode 100644
index 000000000000..a2c8eb15a557
--- /dev/null
+++ b/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CHORNY
+DIST_VERSION=1.94
+inherit perl-module
+
+DESCRIPTION="A persistence framework for session data"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Storable
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=dev-perl/Test-Deep-0.82.0
+ >=dev-perl/Test-Exception-0.150.0
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PERL_RM_FILES=(
+ # Harmful at best
+ t/pod.t
+ # maintainer only
+ t/99postgres.t
+ t/99oracle.t
+)