summaryrefslogtreecommitdiff
path: root/dev-ml/zmq-async/zmq-async-5.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
commit5043a584ce7a3eb644e68694a3266c1a5d2ccba5 (patch)
tree2401f70bb9284c4237ee848dcb65c610db18a643 /dev-ml/zmq-async/zmq-async-5.2.1.ebuild
parentc1503bdaa031111d22d91db2f41dad440fb148e8 (diff)
gentoo auto-resync : 03:06:2023 - 21:32:31
Diffstat (limited to 'dev-ml/zmq-async/zmq-async-5.2.1.ebuild')
-rw-r--r--dev-ml/zmq-async/zmq-async-5.2.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/zmq-async/zmq-async-5.2.1.ebuild b/dev-ml/zmq-async/zmq-async-5.2.1.ebuild
new file mode 100644
index 000000000000..5a7e9347a59c
--- /dev/null
+++ b/dev-ml/zmq-async/zmq-async-5.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Async-aware bindings to ZMQ for OCaml"
+HOMEPAGE="https://github.com/issuu/ocaml-zmq/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/issuu/ocaml-zmq.git"
+else
+ SRC_URI="https://github.com/issuu/ocaml-zmq/archive/${PV}.tar.gz
+ -> ocaml-zmq-${PN}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}"/ocaml-zmq-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/base:=
+ dev-ml/zmq:=
+"
+DEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ test? ( dev-ml/ounit2 )
+"
+
+src_compile() {
+ dune-compile ${DUNE_PKG_NAME}
+}
+
+src_test() {
+ dune-test ${DUNE_PKG_NAME}
+}