summaryrefslogtreecommitdiff
path: root/dev-ml/yojson/yojson-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
commit996a2bda06cb164877d5d952774a6db1b271c2f3 (patch)
tree31930352b48fc7622d658ae37658c57ad9511ef6 /dev-ml/yojson/yojson-2.2.1.ebuild
parent67e5603b2844a6657dd0438fa26626b013e5567f (diff)
gentoo auto-resync : 25:06:2024 - 00:12:20
Diffstat (limited to 'dev-ml/yojson/yojson-2.2.1.ebuild')
-rw-r--r--dev-ml/yojson/yojson-2.2.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/yojson/yojson-2.2.1.ebuild b/dev-ml/yojson/yojson-2.2.1.ebuild
new file mode 100644
index 000000000000..13f7fb0fb563
--- /dev/null
+++ b/dev-ml/yojson/yojson-2.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.07:=[ocamlopt?]
+ dev-ml/sedlex:=
+ !!<dev-ml/seq-0.3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-ml/alcotest )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-2.1.1-dune-seq.patch" )
+
+src_prepare() {
+ default
+ # let's not build this
+ rm bench/dune yojson-bench.opam || die
+}
+
+src_install() {
+ dune_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}