summaryrefslogtreecommitdiff
path: root/dev-ml/uutf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ml/uutf
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ml/uutf')
-rw-r--r--dev-ml/uutf/Manifest2
-rw-r--r--dev-ml/uutf/uutf-1.0.1.ebuild12
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-ml/uutf/Manifest b/dev-ml/uutf/Manifest
index 4d0c119e493d..ddcef2b5e763 100644
--- a/dev-ml/uutf/Manifest
+++ b/dev-ml/uutf/Manifest
@@ -1,3 +1,3 @@
DIST uutf-1.0.1.tbz 22215 BLAKE2B 58cbb8db94024ddaa02c213df4e5321ad33513370c6d1d54ac09f57821df8ac3b330c2659f9aeb0e78dfd15d2f50be714a5a5d6e6d3dcc3f81539c1a6c8c3771 SHA512 35cbee8c82a566f2fe4fcd549936d4c4dc67f5b71bfd3ea97ff25d7cf21cfb77cb5ee313c95ad26a2a61bb84aa48c300bbb79a1a7128c6161e9abe9c390a7d18
-EBUILD uutf-1.0.1.ebuild 1560 BLAKE2B 92fe17e6e2f6c623ef664daaab4efefdba780620cf5d88271d837ded7ed80271e0252548beced6b53a5402a2e8b9f81c9e924e4e1bedef153df4cc77aaa88bae SHA512 0100b5357d033991922f481f9fbd03a61352b1795ec0b73e18d7543630bbfacd3959677e6e35aa0d6c18066da259dcba6dfebda4a65c28e747aea9d5a04f0c5a
+EBUILD uutf-1.0.1.ebuild 1589 BLAKE2B 97df4d6bd39a80eaa5e1cf303b2a7ce5735cf4df7564282b6d0b98b23f6f51063c20f120eda76220aae96c80a95bdb9523bb3494149ea5cb91572b60962b465e SHA512 c56f090492fab0564607595faa7e5765ffd7e13d3bda71e0ed99841bb01183c286b7e7c552e5766626674169bcf88604a6ff9ffa720d21fdd46bd8e38cbc1f65
MISC metadata.xml 390 BLAKE2B c7f6ffb069cf171a47ffaf90b0bbd742d50baa96260e98b21738651722d3006e176f4bc5223932986b2640aa1f091861c7a027f5b4130ed2af77b7ae1e2701bb SHA512 b23f82ba753956db53103340358857cbdee18bc34ee5d5db86d68dc6f04ea419b3f64df7e5fa54ac84e6122eef7236daebda8fbd60aaa7fa59d45714d21aec4a
diff --git a/dev-ml/uutf/uutf-1.0.1.ebuild b/dev-ml/uutf/uutf-1.0.1.ebuild
index 47b4c9ac86d5..ca6cd4708b6e 100644
--- a/dev-ml/uutf/uutf-1.0.1.ebuild
+++ b/dev-ml/uutf/uutf-1.0.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit findlib
@@ -35,7 +35,7 @@ src_test() {
ocamlbuild -use-ocamlfind tests.otarget || die
pushd _build/test || die
./test.native || die
- #Rebuild to avoid mismatches between installed files, bug #604674
+ # Rebuild to avoid mismatches between installed files, bug #604674
popd || die
ocaml pkg/pkg.ml build \
--with-cmdliner "$(usex utftrip true false)" \
@@ -49,9 +49,15 @@ src_install() {
# Can't use opam-installer here as it is an opam dep...
findlib_src_preinst
local nativelibs=""
+
use ocamlopt && nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} _build/src/uutf.a)"
ocamlfind install uutf _build/pkg/META _build/src/uutf.mli _build/src/uutf.cm{a,i} ${nativelibs} || die
+
use utftrip && newbin utftrip.$(usex ocamlopt native byte) utftrip
dodoc CHANGES.md README.md
- use doc && dohtml -r doc/*
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/*
+ fi
}