summaryrefslogtreecommitdiff
path: root/dev-ml/uunf/uunf-15.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 17:57:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 17:57:56 +0000
commit79be8f00e2aa293669b8e22e1ef02d2d5c5f9e25 (patch)
treeee4847d4f20721d819ed71a1e94bb04ff1a8ee4a /dev-ml/uunf/uunf-15.0.0.ebuild
parent61f62e5edc868fc4ae3b92af397397ee5056578a (diff)
gentoo auto-resync : 16:01:2023 - 17:57:56
Diffstat (limited to 'dev-ml/uunf/uunf-15.0.0.ebuild')
-rw-r--r--dev-ml/uunf/uunf-15.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/uunf/uunf-15.0.0.ebuild b/dev-ml/uunf/uunf-15.0.0.ebuild
new file mode 100644
index 000000000000..b4c38684ce6a
--- /dev/null
+++ b/dev-ml/uunf/uunf-15.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode text normalization"
+HOMEPAGE="https://erratique.ch/software/uunf https://github.com/dbuenzli/uunf"
+SRC_URI="https://erratique.ch/software/uunf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/topkg:=
+ dev-ml/uutf:=
+ dev-ml/cmdliner:="
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/findlib"
+OPAM_FILE=opam
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ # bug #798270
+ ulimit -s 11530000
+
+ ocaml pkg/pkg.ml build \
+ || die
+}