summaryrefslogtreecommitdiff
path: root/dev-ml/unidecode/unidecode-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-ml/unidecode/unidecode-0.4.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-ml/unidecode/unidecode-0.4.0.ebuild')
-rw-r--r--dev-ml/unidecode/unidecode-0.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/unidecode/unidecode-0.4.0.ebuild b/dev-ml/unidecode/unidecode-0.4.0.ebuild
new file mode 100644
index 000000000000..35cfaf39fd6c
--- /dev/null
+++ b/dev-ml/unidecode/unidecode-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Convert unicode strings into its ASCII representation"
+HOMEPAGE="https://github.com/geneweb/unidecode"
+SRC_URI="https://github.com/geneweb/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="test? ( dev-ml/ounit2 )"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+src_install() {
+ dune_src_install
+ mv "${D}"/usr/bin/unidecode{,-gw} || die
+}