summaryrefslogtreecommitdiff
path: root/dev-ml/tyxml/tyxml-4.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
commit454de691f3543d47dc89cd0b137eaa9ea4640cd3 (patch)
tree90ec469ff7d2e1b1fac0b0f98f32d49dacb30278 /dev-ml/tyxml/tyxml-4.5.0.ebuild
parente393c0503a79342594a61547dc43f80f8bcc086e (diff)
gentoo auto-resync : 21:12:2022 - 13:54:08
Diffstat (limited to 'dev-ml/tyxml/tyxml-4.5.0.ebuild')
-rw-r--r--dev-ml/tyxml/tyxml-4.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/tyxml/tyxml-4.5.0.ebuild b/dev-ml/tyxml/tyxml-4.5.0.ebuild
new file mode 100644
index 000000000000..192acf0b7965
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A library for building correct HTML and SVG documents"
+HOMEPAGE="https://github.com/ocsigen/tyxml"
+SRC_URI="https://github.com/ocsigen/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/markup:=
+ dev-ml/ppxlib:=
+ dev-ml/uutf:=
+ dev-ml/re:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/alcotest
+ dev-ml/reason
+)"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )