summaryrefslogtreecommitdiff
path: root/dev-ml/timezone/timezone-0.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
commit0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (patch)
treed48a200142b883af377722ab54ec0c1d8c19912f /dev-ml/timezone/timezone-0.17.0.ebuild
parent6a7029e0f7370d4d5dfe9e31cc2719a870482392 (diff)
gentoo auto-resync : 16:06:2024 - 00:09:44
Diffstat (limited to 'dev-ml/timezone/timezone-0.17.0.ebuild')
-rw-r--r--dev-ml/timezone/timezone-0.17.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/timezone/timezone-0.17.0.ebuild b/dev-ml/timezone/timezone-0.17.0.ebuild
new file mode 100644
index 000000000000..277ad039bffb
--- /dev/null
+++ b/dev-ml/timezone/timezone-0.17.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Time-zone handling for OCaml"
+HOMEPAGE="https://github.com/janestreet/timezone"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/core:${SLOT}[ocamlopt?]
+ dev-ml/ppx_jane:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"