summaryrefslogtreecommitdiff
path: root/dev-ml/stdune/stdune-3.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 03:00:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 03:00:52 +0000
commit4b70b249bd1fe7302633ca0b4f7abd22dd269d02 (patch)
treec39fc6439ab9c72db6a0f070fe02312591ccc963 /dev-ml/stdune/stdune-3.6.2.ebuild
parent182063dd85a03f2086258946276c8967945ffe95 (diff)
gentoo auto-resync : 31:01:2023 - 03:00:52
Diffstat (limited to 'dev-ml/stdune/stdune-3.6.2.ebuild')
-rw-r--r--dev-ml/stdune/stdune-3.6.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/stdune/stdune-3.6.2.ebuild b/dev-ml/stdune/stdune-3.6.2.ebuild
new file mode 100644
index 000000000000..7ee771448037
--- /dev/null
+++ b/dev-ml/stdune/stdune-3.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dune's unstable standard library"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+DEPEND="
+ dev-ml/pp:=[ocamlopt?]
+ ~dev-ml/dyn-${PV}:=[ocamlopt?]
+ ~dev-ml/ordering-${PV}:=[ocamlopt?]
+ >=dev-ml/csexp-1.5:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}