summaryrefslogtreecommitdiff
path: root/dev-ml/stdcompat/stdcompat-19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
commite80777b54c5b430ca044e16878f59a2020423d48 (patch)
treeb72b3422d129532b8f0ceb415c6e7c5109e3fe75 /dev-ml/stdcompat/stdcompat-19.ebuild
parentaa61828f226f3b30e6939408847d914a145fdf35 (diff)
gentoo auto-resync : 10:11:2022 - 09:27:33
Diffstat (limited to 'dev-ml/stdcompat/stdcompat-19.ebuild')
-rw-r--r--dev-ml/stdcompat/stdcompat-19.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/stdcompat/stdcompat-19.ebuild b/dev-ml/stdcompat/stdcompat-19.ebuild
new file mode 100644
index 000000000000..e6001579ae46
--- /dev/null
+++ b/dev-ml/stdcompat/stdcompat-19.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Compatibility module for OCaml standard library"
+HOMEPAGE="https://github.com/thierry-martinez/stdcompat"
+SRC_URI="https://github.com/thierry-martinez/stdcompat/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0/${PV}"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune
+ dev-ml/findlib[ocamlopt]"
+
+src_configure () {
+ econf --libdir="${EPREFIX}"/usr/$(get_libdir)/ocaml
+}