summaryrefslogtreecommitdiff
path: root/dev-ml/sedlex/sedlex-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /dev-ml/sedlex/sedlex-3.0.ebuild
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'dev-ml/sedlex/sedlex-3.0.ebuild')
-rw-r--r--dev-ml/sedlex/sedlex-3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/sedlex/sedlex-3.0.ebuild b/dev-ml/sedlex/sedlex-3.0.ebuild
new file mode 100644
index 000000000000..7cf89cfc99cc
--- /dev/null
+++ b/dev-ml/sedlex/sedlex-3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="An OCaml lexer generator for Unicode"
+HOMEPAGE="https://github.com/ocaml-community/sedlex"
+SRC_URI="https://github.com/ocaml-community/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/gen:=
+ >=dev-ml/ppxlib-0.26:=
+ dev-ml/uchar:=
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ebegin "Building"
+ dune build @install --display short --profile release \
+ --ignore-promoted-rules
+ eend $? || die
+}
+
+dune_src_test() {
+ ebegin "Testing"
+ dune runtest --display short --profile release \
+ --ignore-promoted-rules
+ eend $? || die
+}