summaryrefslogtreecommitdiff
path: root/dev-ml/reason
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ml/reason
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ml/reason')
-rw-r--r--dev-ml/reason/Manifest3
-rw-r--r--dev-ml/reason/metadata.xml17
-rw-r--r--dev-ml/reason/reason-3.7.0-r1.ebuild33
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/reason/Manifest b/dev-ml/reason/Manifest
new file mode 100644
index 000000000000..abbde7d57787
--- /dev/null
+++ b/dev-ml/reason/Manifest
@@ -0,0 +1,3 @@
+DIST reason-3.7.0.tgz 1188558 BLAKE2B e5d9cebf98f95824b78d440fa9f91460eae1a1ed44a38e74be4f9404a0bdec046578d25febdf55c266466bffc16b4449e982f157b6d5aabfa1d507fdc3eb5aaf SHA512 263059970c88e105f09e8e47b3967add11fda31a79942f573c90a0ccb04149a5baaf3c3bbd1dd5a085ccdd3e63505f84855dd0fb888d34a9e9eda3248f300e24
+EBUILD reason-3.7.0-r1.ebuild 636 BLAKE2B 25d52a46afe573ecf766f65266946ca1bdd31de020bd430d0f796f3fda702c39c7c13750db9d19ff76c345908a2502a3069a75b483069bfdbe29dd9da28b7a24 SHA512 95d96c88df44e4a0ed0b9c5deb9b2872211c905b0b94bd9a7053d338c091ee087f07f9355e7f9e0f95ab0a440ce6091b4ec9d174019afa3a388a81596c329bd2
+MISC metadata.xml 582 BLAKE2B a339a232ca259236ae8583cacc17e45b262d7553156d0c7583cf1ca2ad94c73ebc3c20f0d806f29f1de2d064ad08f28d61cfce49fba70498084ffe4b017defdd SHA512 cfb0605806b04afa3b701c24ffa8e3177646b8d7999f8abc4530dce3f7f9ae99c8abeccf67a0089b8293660298421ce89ff8e1dad4f300c53ae6d259f9dd62e4
diff --git a/dev-ml/reason/metadata.xml b/dev-ml/reason/metadata.xml
new file mode 100644
index 000000000000..4fc59b478a35
--- /dev/null
+++ b/dev-ml/reason/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Reason provides a new ES6-inspired syntax for OCaml. It's also the umbrella
+ project for a set of tools for the OCaml and JavaScript ecosystems.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/reasonml/reason/issues/</bugs-to>
+ <remote-id type="github">reasonml/reason</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/reason/reason-3.7.0-r1.ebuild b/dev-ml/reason/reason-3.7.0-r1.ebuild
new file mode 100644
index 000000000000..c5b7bcec869d
--- /dev/null
+++ b/dev-ml/reason/reason-3.7.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io"
+SRC_URI="https://registry.npmjs.org/@esy-ocaml/${PN}/-/${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/fix:=
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ dev-ml/utop:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune_src_install reason
+ dune_src_install rtop
+
+ dodoc *.md
+}