summaryrefslogtreecommitdiff
path: root/dev-ml/reason/reason-3.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
commit49307b439ea0ae14beb0772de83e70297ae8356c (patch)
tree02f22afc29810c4558bf87d13c56f288d43fecc3 /dev-ml/reason/reason-3.9.0-r1.ebuild
parent99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (diff)
gentoo auto-resync : 09:07:2023 - 04:23:59
Diffstat (limited to 'dev-ml/reason/reason-3.9.0-r1.ebuild')
-rw-r--r--dev-ml/reason/reason-3.9.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/reason/reason-3.9.0-r1.ebuild b/dev-ml/reason/reason-3.9.0-r1.ebuild
new file mode 100644
index 000000000000..d5e02288741c
--- /dev/null
+++ b/dev-ml/reason/reason-3.9.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io/
+ https://github.com/reasonml/reason/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/reasonml/${PN}.git"
+else
+ SRC_URI="https://github.com/reasonml/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/dune-build-info:=
+ dev-ml/fix:=
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_derivers:=
+ dev-ml/ppxlib:=
+ dev-ml/utop:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune-install reason rtop
+
+ dodoc *.md docs/*.md
+}