summaryrefslogtreecommitdiff
path: root/dev-ml/ptime/ptime-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 16:00:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 16:00:10 +0100
commit9f51c386724b9543e88a9c0e1be57d44326f3116 (patch)
treed351bdf5964a53a79ca2c9cec1123b234cd321ed /dev-ml/ptime/ptime-1.1.0.ebuild
parentfdfde9fd41778789aaab6711adb9e4cc31c28360 (diff)
gentoo auto-resync : 27:08:2023 - 16:00:10
Diffstat (limited to 'dev-ml/ptime/ptime-1.1.0.ebuild')
-rw-r--r--dev-ml/ptime/ptime-1.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ptime/ptime-1.1.0.ebuild b/dev-ml/ptime/ptime-1.1.0.ebuild
new file mode 100644
index 000000000000..491270a410c5
--- /dev/null
+++ b/dev-ml/ptime/ptime-1.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit opam findlib
+
+DESCRIPTION="POSIX time for OCaml"
+HOMEPAGE="
+ https://erratique.ch/software/ptime
+ https://github.com/dbuenzli/ptime
+ https://opam.ocaml.org/packages/ptime/
+"
+SRC_URI="https://erratique.ch/software/ptime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-ml/topkg
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}