summaryrefslogtreecommitdiff
path: root/dev-ml/ppxlib/ppxlib-0.29.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-ml/ppxlib/ppxlib-0.29.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-ml/ppxlib/ppxlib-0.29.0.ebuild')
-rw-r--r--dev-ml/ppxlib/ppxlib-0.29.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/ppxlib-0.29.0.ebuild b/dev-ml/ppxlib/ppxlib-0.29.0.ebuild
new file mode 100644
index 000000000000..5dcf6f546bc2
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.29.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+# Note that new "major" versions may change which OCaml version they support
+# See:
+# https://github.com/ocaml-ppx/ppxlib/issues/243
+# https://github.com/ocaml-ppx/ppxlib/issues/232
+
+DESCRIPTION="Base library and tools for ppx rewriters"
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.2.0:=
+ dev-ml/sexplib0:=
+ dev-ml/stdlib-shims:=
+ >=dev-ml/ppx_derivers-1.2.1:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/findlib:=
+ >=dev-ml/base-0.11.0:=
+ dev-ml/cinaps:=
+ dev-ml/re:=
+ >=dev-ml/stdio-0.11.0:=
+ )
+"
+BDEPEND=">=dev-ml/dune-2.8"