summaryrefslogtreecommitdiff
path: root/dev-ml/ppxlib/ppxlib-0.24.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 01:36:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 01:36:49 +0000
commit65e0298c5630af19b2b181c2dd143bb47aa54231 (patch)
tree4dfaf06d77acbaff8f85b3d5f9848b01ab7fe236 /dev-ml/ppxlib/ppxlib-0.24.0-r1.ebuild
parentd5f4fe0e51ffa8d74055615bc4f0e2e950b5dadb (diff)
gentoo auto-resync : 30:12:2023 - 01:36:49
Diffstat (limited to 'dev-ml/ppxlib/ppxlib-0.24.0-r1.ebuild')
-rw-r--r--dev-ml/ppxlib/ppxlib-0.24.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/ppxlib-0.24.0-r1.ebuild b/dev-ml/ppxlib/ppxlib-0.24.0-r1.ebuild
new file mode 100644
index 000000000000..f15f96e90ae0
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.24.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+# Note that new "major" versions may change which OCaml version they support
+# See:
+# https://github.com/ocaml-ppx/ppxlib/issues/243
+# https://github.com/ocaml-ppx/ppxlib/issues/232
+
+DESCRIPTION="Base library and tools for ppx rewriters"
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=[ocamlopt?]
+ >=dev-ml/ocaml-migrate-parsetree-2.2.0:=[ocamlopt?]
+ dev-ml/sexplib0:=[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ >=dev-ml/ppx_derivers-1.2.1:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/findlib:=[ocamlopt?]
+ >=dev-ml/base-0.11.0:=[ocamlopt?]
+ dev-ml/cinaps:=
+ dev-ml/re:=
+ >=dev-ml/stdio-0.11.0:=[ocamlopt?]
+ )
+"
+BDEPEND=">=dev-ml/dune-2.8"