summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_tools/ppx_tools-6.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /dev-ml/ppx_tools/ppx_tools-6.6.ebuild
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'dev-ml/ppx_tools/ppx_tools-6.6.ebuild')
-rw-r--r--dev-ml/ppx_tools/ppx_tools-6.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/ppx_tools/ppx_tools-6.6.ebuild b/dev-ml/ppx_tools/ppx_tools-6.6.ebuild
new file mode 100644
index 000000000000..0716cf4a4310
--- /dev/null
+++ b/dev-ml/ppx_tools/ppx_tools-6.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+MY_PV=$(ver_rs 2 '+')
+DESCRIPTION="Tools for authors of ppx rewriters"
+HOMEPAGE="https://github.com/alainfrisch/ppx_tools"
+SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-$(ver_rs 2 '-')"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/cppo
+"