summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_pipebang
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ml/ppx_pipebang
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ml/ppx_pipebang')
-rw-r--r--dev-ml/ppx_pipebang/Manifest4
-rw-r--r--dev-ml/ppx_pipebang/ppx_pipebang-0.14.0.ebuild2
-rw-r--r--dev-ml/ppx_pipebang/ppx_pipebang-0.15.0.ebuild22
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-ml/ppx_pipebang/Manifest b/dev-ml/ppx_pipebang/Manifest
index 1e9ec0589a43..994efc288463 100644
--- a/dev-ml/ppx_pipebang/Manifest
+++ b/dev-ml/ppx_pipebang/Manifest
@@ -1,3 +1,5 @@
DIST ppx_pipebang-0.14.0.tar.gz 3766 BLAKE2B a2e99dd5e27ddbca5d77b1c215757d8d0d2d54b53511f0db93a09a16c25b5c5e429a08c8d42c7e4843eeb23c346649dea5700c445afe176f4b1625340901b6c1 SHA512 b07004aef0865c877f8f814068b514298568078785586933f400350d1a1dae3eb4aafe1ba4f12e17a3e2a3945297162c4a725ebfbc153e80b412c6086019959a
-EBUILD ppx_pipebang-0.14.0.ebuild 602 BLAKE2B c7c7a1deceef6131c0d1e87e8a0e794cd254d97977d9e75a04df173c1f361d80a309141d96dc7c94d92bd1ca041790b6cb9954fce44b6957df618b30d9e832ab SHA512 ed574dc9af640f4199da6c05c1b932aae8bc31e0fd76e2a3e2b4360c153dd0c0af1061b4d5cf62d522d99ea460e87f28e4b6f83af1e78994a351d6c2fdd63786
+DIST ppx_pipebang-0.15.0.tar.gz 3759 BLAKE2B 6d2a45a4b803a777dcf055acccbea3e54a86458d01032efd01d204cf3426b496b9d91047216c11a424ef5e7ff92fc729d1ef8fb616f807c21f512be52013665a SHA512 778dae2cd6176f9ce18f20486e16f6f76e9137095759b29ddc10fee15d8a21f51fff94245c4a750ae68cd75edbd06b9cad6ff1b56aacb38ac9e6d7d71c0bf701
+EBUILD ppx_pipebang-0.14.0.ebuild 609 BLAKE2B 5ef5cf0e06f2a95a989c6f475054dfb3ae07ed66540f896c6bc5546ba4e7c1f7eed9905ebfb16c6dab35964964987db5f59a47dbb0848db405e0532b407a4f0b SHA512 ba51a7c73dc026c12ba313e3041af5e9b10f6ac2d73ee34c989a7ba70140c8ac06d4fc1c74d694a976544fe60e2793f6f7e6d9a4f6eb62154a3ab3004bdf390a
+EBUILD ppx_pipebang-0.15.0.ebuild 583 BLAKE2B 0dc8537b48784be9c6d8cc817b4bd51e9e5da1e38af009cb93d675527e8770067ef998d930ce045fa0d4350142ba0ffa1fd4daf5853c67076d4f19a90920976c SHA512 17cfbdee393a7a89de1f579ef44daf63efdcf863588493c945db6c8f5ccb168e348ee64790249c133196cd2bb135555602b9ca64ee6429c42537e38684414417
MISC metadata.xml 426 BLAKE2B d8e84eb6a88f814f66ccc7e13e0e2b7fea790c1d416af04cc9e156736d1b78519ffbb627a31b3489677ceb7894061b4f6d6ae8db7da9ed1032d5b5fa190030f0 SHA512 081f8749c443bd8777e51ba2ccdc3155cf84ddfb0a903e53abbbe48d958b3c1cf8464175a9bef2f378a05bacff451e664afa2ac397cbcabb3f79b1970c970387
diff --git a/dev-ml/ppx_pipebang/ppx_pipebang-0.14.0.ebuild b/dev-ml/ppx_pipebang/ppx_pipebang-0.14.0.ebuild
index a11ccbe392a4..70ea6e43c8ff 100644
--- a/dev-ml/ppx_pipebang/ppx_pipebang-0.14.0.ebuild
+++ b/dev-ml/ppx_pipebang/ppx_pipebang-0.14.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0"
SLOT="0/${PV}"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
IUSE="+ocamlopt"
DEPEND="
diff --git a/dev-ml/ppx_pipebang/ppx_pipebang-0.15.0.ebuild b/dev-ml/ppx_pipebang/ppx_pipebang-0.15.0.ebuild
new file mode 100644
index 000000000000..40b93c106d46
--- /dev/null
+++ b/dev-ml/ppx_pipebang/ppx_pipebang-0.15.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A ppx rewriter that inlines reverse application operators |> and |!"
+HOMEPAGE="https://github.com/janestreet/ppx_pipebang"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.08
+ >=dev-ml/ppxlib-0.23.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"