summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_module_timer/ppx_module_timer-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
commit8164a4e49d69b936f2d820456e48468dc0e241ad (patch)
tree72c381896b721d4947b8f65f0cadceef779b99ae /dev-ml/ppx_module_timer/ppx_module_timer-0.16.0.ebuild
parentc3ec60d8953748433a04137e04480e9c1a36ed4c (diff)
gentoo auto-resync : 02:07:2023 - 11:30:05
Diffstat (limited to 'dev-ml/ppx_module_timer/ppx_module_timer-0.16.0.ebuild')
-rw-r--r--dev-ml/ppx_module_timer/ppx_module_timer-0.16.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ppx_module_timer/ppx_module_timer-0.16.0.ebuild b/dev-ml/ppx_module_timer/ppx_module_timer-0.16.0.ebuild
new file mode 100644
index 000000000000..689ef33b1ce5
--- /dev/null
+++ b/dev-ml/ppx_module_timer/ppx_module_timer-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Ppx rewriter that records top-level module startup times"
+HOMEPAGE="https://github.com/janestreet/ppx_module_timer"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/time_now:${SLOT}
+ >=dev-ml/ppxlib-0.28.0:=
+"
+RDEPEND="${DEPEND}"