summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild')
-rw-r--r--dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild b/dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild
new file mode 100644
index 000000000000..6c37bba4923e
--- /dev/null
+++ b/dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Code style checker for Jane Street Packages"
+HOMEPAGE="https://github.com/janestreet/ppx_js_style"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ dev-ml/octavius:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"