summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_inline_test/ppx_inline_test-0.15.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-ml/ppx_inline_test/ppx_inline_test-0.15.0-r3.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-ml/ppx_inline_test/ppx_inline_test-0.15.0-r3.ebuild')
-rw-r--r--dev-ml/ppx_inline_test/ppx_inline_test-0.15.0-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_inline_test/ppx_inline_test-0.15.0-r3.ebuild b/dev-ml/ppx_inline_test/ppx_inline_test-0.15.0-r3.ebuild
new file mode 100644
index 000000000000..c54ad31da8b2
--- /dev/null
+++ b/dev-ml/ppx_inline_test/ppx_inline_test-0.15.0-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Syntax extension for writing in-line tests in ocaml code"
+HOMEPAGE="https://github.com/janestreet/ppx_inline_test"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+# https://bugs.gentoo.org/749291#c2
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-ml/ppxlib-0.29.0:=
+ dev-ml/base:=
+ dev-ml/time_now:${SLOT}
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-pr39.patch )