summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_expect/ppx_expect-0.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
commit5e41a38157bb40e8513e8e34426e85faba672fe7 (patch)
tree38e9365afd56c161d0e970ddf5420b2585130587 /dev-ml/ppx_expect/ppx_expect-0.17.0.ebuild
parent0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (diff)
gentoo auto-resync : 14:06:2024 - 00:09:04
Diffstat (limited to 'dev-ml/ppx_expect/ppx_expect-0.17.0.ebuild')
-rw-r--r--dev-ml/ppx_expect/ppx_expect-0.17.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/ppx_expect-0.17.0.ebuild b/dev-ml/ppx_expect/ppx_expect-0.17.0.ebuild
new file mode 100644
index 000000000000..bf163bf0869d
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-0.17.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_expect"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+# https://bugs.gentoo.org/749291#c2
+#RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_here:${SLOT}[ocamlopt?]
+ dev-ml/ppx_inline_test:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+ dev-ml/stdio:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"