summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_expect/ppx_expect-0.15.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 02:53:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 02:53:24 +0000
commitb8ec9071f5d20d8518b02d0077428b2c9f88861b (patch)
tree6214c0d63a2bd5ae464941924a90f415687fa63c /dev-ml/ppx_expect/ppx_expect-0.15.1-r1.ebuild
parentbdf6e70da7a28f45617c02a251bb6b3844202bc5 (diff)
gentoo auto-resync : 29:01:2023 - 02:53:24
Diffstat (limited to 'dev-ml/ppx_expect/ppx_expect-0.15.1-r1.ebuild')
-rw-r--r--dev-ml/ppx_expect/ppx_expect-0.15.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/ppx_expect-0.15.1-r1.ebuild b/dev-ml/ppx_expect/ppx_expect-0.15.1-r1.ebuild
new file mode 100644
index 000000000000..bb0f3e768249
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-0.15.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_expect"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+# https://bugs.gentoo.org/749291#c2
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/ppxlib:=
+ dev-ml/ppx_inline_test:${SLOT}
+ dev-ml/re:=
+"
+DEPEND="${RDEPEND}"