summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild')
-rw-r--r--dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild b/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
new file mode 100644
index 000000000000..9d7682d713fc
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_expect"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ >=dev-ml/ppx_here-0.14.0:=
+ >=dev-ml/ppx_inline_test-0.14.1:=
+ >=dev-ml/stdio-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/ppx_jane
+ )"
+# https://bugs.gentoo.org/749291#c2
+RESTRICT=test