summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild')
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild b/dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild
new file mode 100644
index 000000000000..73a1495d16a7
--- /dev/null
+++ b/dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving"
+SRC_URI="https://github.com/ocaml-ppx/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_derivers:=
+ >=dev-ml/ppxlib-0.20.0:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ test? ( dev-ml/ounit2 )"