summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild b/dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..b7479abd2f4f
--- /dev/null
+++ b/dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Standard library for ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_core"
+SRC_URI="https://github.com/janestreet/ppx_core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ocaml-compiler-libs:=
+ dev-ml/ppx_ast:=
+ dev-ml/ppx_traverse_builtins:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"