summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_base/ppx_base-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ml/ppx_base/ppx_base-0.15.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ml/ppx_base/ppx_base-0.15.0.ebuild')
-rw-r--r--dev-ml/ppx_base/ppx_base-0.15.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ppx_base/ppx_base-0.15.0.ebuild b/dev-ml/ppx_base/ppx_base-0.15.0.ebuild
new file mode 100644
index 000000000000..5138415a4c32
--- /dev/null
+++ b/dev-ml/ppx_base/ppx_base-0.15.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Base set of ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_base"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ppx_cold:${SLOT}
+ dev-ml/ppx_enumerate:${SLOT}
+ dev-ml/ppx_hash:${SLOT}
+"
+RDEPEND="${DEPEND}"