summaryrefslogtreecommitdiff
path: root/dev-ml/pgocaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/pgocaml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/pgocaml')
-rw-r--r--dev-ml/pgocaml/Manifest3
-rw-r--r--dev-ml/pgocaml/metadata.xml11
-rw-r--r--dev-ml/pgocaml/pgocaml-2.3.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/pgocaml/Manifest b/dev-ml/pgocaml/Manifest
new file mode 100644
index 000000000000..68f94fedacfb
--- /dev/null
+++ b/dev-ml/pgocaml/Manifest
@@ -0,0 +1,3 @@
+DIST pgocaml-2.3.tgz 90383 BLAKE2B 3e536b4a310846688a3fd55b7a807e1aeebd12ce5f551d66572f8f3014007058a6843da1bfaf6acf16d0c1ab8b8c61551b85c29b95a79d604e9314849c1b1e05 SHA512 f42ca8ccf31f9e03cfa9f81a9cd19c2a6010c33f5a578e76924683fd10ab4acf2727b09b71c5a8f200bc39765a5d876a289976fea367b49ae54335c007fd3ff7
+EBUILD pgocaml-2.3.ebuild 760 BLAKE2B e97d456271daa825b220bd3941465a3c246d8822a3e3db83a732baaf1c3355070fc6f4920e87cdae8898367cd62ffb691dfc2d57115735451d6f9b4d676be698 SHA512 077437b8d6c82b34c60dfa2ba5cf37f9f27dc7f01b0b2a995f39fb1cbc748867ad13696c8efca8a97c18fa1a8a3f1415aa6d8fbdc9e4f7c31725de8df1c52958
+MISC metadata.xml 325 BLAKE2B 9e20ffdb6978964401f1f7443d3618af20c872807d2830a61ffb68ddd30305e5f83e77b0a10ac4fe9abecd9dfb5c954fb68b932aaf16101de8335e3c9632fbe8 SHA512 83d60959aa467616d4d7d53fa5c29f7a8b2a49dae6a5d6d400ad6c44ad571c0a3375000662a99435570d257d871fd78e3f64c48edcfc6fcdfeb27be9fec8a338
diff --git a/dev-ml/pgocaml/metadata.xml b/dev-ml/pgocaml/metadata.xml
new file mode 100644
index 000000000000..a00e7949c4bb
--- /dev/null
+++ b/dev-ml/pgocaml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <use>
+ <flag name="camlp4">Enable PG'Ocaml syntax extension.</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/pgocaml/pgocaml-2.3.ebuild b/dev-ml/pgocaml/pgocaml-2.3.ebuild
new file mode 100644
index 000000000000..121edf6351c3
--- /dev/null
+++ b/dev-ml/pgocaml/pgocaml-2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="PG'OCaml is a set of OCaml bindings for the PostgreSQL database"
+HOMEPAGE="http://pgocaml.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1597/${P}.tgz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+camlp4 doc"
+
+DEPEND="dev-ml/calendar:=
+ dev-ml/csv:=
+ dev-ml/ocaml-re:=
+ camlp4? ( dev-ml/camlp4:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "CHANGELOG.txt"
+ "doc/BUGS.txt" "doc/CONTRIBUTORS.txt"
+ "doc/HOW_IT_WORKS.txt" "doc/PROFILING.txt"
+ )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4 p4)" oasis_src_configure
+}