summaryrefslogtreecommitdiff
path: root/dev-ml/pcre-ocaml/pcre-ocaml-7.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/pcre-ocaml/pcre-ocaml-7.3.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.3.3.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.3.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.3.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.3.3.ebuild
new file mode 100644
index 000000000000..7f1a5f8b9512
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/${PV}/pcre-${PV}.tbz -> ${P}.tbz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/base
+ dev-ml/stdio
+ dev-ml/configurator
+"
+
+S="${WORKDIR}/pcre-${PV}"
+
+src_compile() {
+ jbuilder build @install || die
+}
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam_src_install pcre
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}