summaryrefslogtreecommitdiff
path: root/dev-ml/pcre-ocaml/pcre-ocaml-7.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/pcre-ocaml/pcre-ocaml-7.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.3.0.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.3.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.3.0.ebuild
new file mode 100644
index 000000000000..869d45b107cf
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/${PV}/pcre-${PV}.tbz -> ${P}.tbz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/base
+ dev-ml/stdio
+ dev-ml/configurator
+"
+
+S="${WORKDIR}/pcre-${PV}"
+
+src_compile() {
+ jbuilder build @install || die
+}
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam_src_install pcre
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}