summaryrefslogtreecommitdiff
path: root/dev-ml/ordering/ordering-3.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
commit4fe228ee9aa3b9b825d54ace549a5517e153e8bd (patch)
tree90a261e3ea59b80722d70d3c42f3e40d16c9f8dd /dev-ml/ordering/ordering-3.11.1.ebuild
parentadc09cc4e6ebf7931735c02c0c272b4b885c2b30 (diff)
gentoo auto-resync : 09:06:2024 - 00:08:13
Diffstat (limited to 'dev-ml/ordering/ordering-3.11.1.ebuild')
-rw-r--r--dev-ml/ordering/ordering-3.11.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ordering/ordering-3.11.1.ebuild b/dev-ml/ordering/ordering-3.11.1.ebuild
new file mode 100644
index 000000000000..66c9a48a8b2b
--- /dev/null
+++ b/dev-ml/ordering/ordering-3.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Element ordering"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ${PN}
+}